2009年11月10日

[debian-users:53296] etchからlennyでハマっています。

塩路@横浜国大と申します。

qmailで運用しているメイルサーバをetchからlennyへアップグレード
しようとしてハマっています。
引っかかっているのはperlのようです。
アップグレードの最中にうまくいかなくなり、apt-get -f installを
要求されたのでやってみると、

# apt-get -f install
Reading package lists... 0%Reading package lists... 100%Reading package lists... Done
Building dependency tree... 0%Building dependency tree... 0%Building dependency tree... 50%Building dependency tree... 50%Building dependency tree
Reading state information... 0%Reading state information... 0%Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
libisccc0 libbind9-0 libdns22 libisccfg1 update-inetd openbsd-inetd
liblwres9 libdb4.4 libisc11
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
perl
Suggested packages:
perl-doc libterm-readline-gnu-perl libterm-readline-perl-perl
The following packages will be upgraded:
perl
1 upgraded, 0 newly installed, 0 to remove and 160 not upgraded.
14 not fully installed or removed.
Need to get 0B/4549kB of archives.
After this operation, 98.3kB disk space will be freed.
Do you want to continue [Y/n]?
debconf: delaying package configuration, since apt-utils is not installed
(Reading database ... 21324 files and directories currently installed.)
Preparing to replace perl 5.8.8-7etch6 (using .../perl_5.10.0-19lenny2_i386.deb) ...
Unpacking replacement perl ...
dpkg: error processing /var/cache/apt/archives/perl_5.10.0-19lenny2_i386.deb (--unpack):
trying to overwrite `/usr/bin/ptardiff', which is also in package libarchive-tar-perl
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/perl_5.10.0-19lenny2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

となります。また、apt-get -s remove libarchive-tar-perlの結果は、

# apt-get -s remove libarchive-tar-perl
Reading package lists... 0%Reading package lists... 0%Reading package lists... 28%Reading package lists... Done
Building dependency tree... 0%Building dependency tree... 0%Building dependency tree... 50%Building dependency tree... 50%Building dependency tree... 76%Building dependency tree
Reading state information... 0%Reading state information... 0%Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
libcompress-raw-zlib-perl: Depends: perl (>= 5.10.0-19) but 5.8.8-7etch6 is to be installed
libdigest-sha1-perl: Depends: perl (>= 5.10.0-9) but 5.8.8-7etch6 is to be installed
libhtml-parser-perl: Depends: perl (>= 5.10.0-19lenny2) but 5.8.8-7etch6 is to be installed
libnet-dns-perl: Depends: perl (>= 5.10.0-11) but 5.8.8-7etch6 is to be installed
libsocket6-perl: Depends: perl (>= 5.10.0-10) but 5.8.8-7etch6 is to be installed
perl: Depends: perl-base (= 5.8.8-7etch6) but 5.10.0-19lenny2 is to be installed
Recommends: perl-doc but it is not going to be installed
perl-modules: Depends: perl (>= 5.10.0-1) but 5.8.8-7etch6 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

となります。
dpkg -i perl_5.10.0-19lenny2_i386.deb
もやってみましたが、apt-get -f installと同じような具合です。

どうしたらいいものか弱っているのですが、アドバイスを頂け
ないでしょうか。

塩路直樹

投稿者 xml-rpc : 2009年11月10日 10:43
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/90293
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。