2009年10月26日

[debian-users:53244] [Translate] [SECURITY] [DSA 1919-1] New smarty packages fix severalvulnerabilities

かねこです。
URL 等は Debian-security-announce メーリングリストの元記事を確認
ください。

------>8------------>8------------>8------------>8------------>8-
- ------------------------------------------------------------------------
Debian Security Advisory DSA-1919-1 security@xxxxx
http://www.debian.org/security/ Thijs Kinkhorst

October 25, 2009 http://www.debian.org/security/faq
- ------------------------------------------------------------------------

Package : smarty
Vulnerability : 複数
Problem type : リモート
Debian-specific: いいえ
CVE Id(s) : CVE-2008-4810 CVE-2009-1669
Debian Bug : 504328 529810

PHP テンプレートシステム smarty に、リモートから攻撃可能な複数の問題が
発見されました。The Common Vulnerabilities and Exposures project は以下
の問題を認識しています。

CVE-2008-4810

_expand_quoted_text 関数が、テンプレートの一部の制約、例えば 関数呼
び出しや PHP コードの実行など、の迂回を許してしまいます。

CVE-2009-1669

smarty_function_math 関数が、math 関数の等式アトリビュート中にシェル
メタキャラクタを含ませることで、状況依存で攻撃者に任意のコードの実行
を許します。

旧安定版 (oldstable) ディストリビューション (etch) では、これらの問題は
バージョン 2.6.14-1etch2 で修正されています。

安定版 (stable) ディストリビューション (lenny) では、これらの問題はバー
ジョン 2.6.20-1.2 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、これらの問題は近
く修正予定です。

直ぐに smarty パッケージをアップグレードすることを勧めます。


アップグレード手順
------------------

wget url
でファイルを取得できます。
dpkg -i file.deb
で参照されたファイルをインストールできます。

apt-get パッケージマネージャを用いている場合には、本メールのフッタ記載の
行を sources.list に加えて、

apt-get update
を実行して内部データベースを更新し、
apt-get upgrade
によって修正されたパッケージをインストールしてください。

本メールのフッタ記載の設定を自ホストの設定に加えることにより、自動更新を
行うこともできます。

Debian GNU/Linux 4.0 alias etch
- -------------------------------

ソースアーカイブ:

http://security.debian.org/pool/updates/main/s/smarty/smarty_2.6.14-1etch2.dsc
Size/MD5 checksum: 958 f061c466cef93df89e677aeb72101910
http://security.debian.org/pool/updates/main/s/smarty/smarty_2.6.14.orig.tar.gz
Size/MD5 checksum: 144986 9186796ddbc29191306338dea9d632a0
http://security.debian.org/pool/updates/main/s/smarty/smarty_2.6.14-1etch2.diff.gz
Size/MD5 checksum: 4290 0ef9a669c127818f5ff084e2829738e9

アーキテクチャに依存しないパッケージ:

http://security.debian.org/pool/updates/main/s/smarty/smarty_2.6.14-1etch2_all.deb
Size/MD5 checksum: 183300 d0ac954aad344f20b5933b09593b2968

Debian GNU/Linux 5.0 alias lenny
- --------------------------------

ソースアーカイブ:

http://security.debian.org/pool/updates/main/s/smarty/smarty_2.6.20-1.2.dsc
Size/MD5 checksum: 1409 f280e2733ef52ff621891f99b26386f3
http://security.debian.org/pool/updates/main/s/smarty/smarty_2.6.20-1.2.diff.gz
Size/MD5 checksum: 4876 4d729d18d7efe68e1ce3023149436c01
http://security.debian.org/pool/updates/main/s/smarty/smarty_2.6.20.orig.tar.gz
Size/MD5 checksum: 158091 35f405b2418a26a895302a2ce5bf89d2

アーキテクチャに依存しないパッケージ:

http://security.debian.org/pool/updates/main/s/smarty/smarty_2.6.20-1.2_all.deb
Size/MD5 checksum: 204412 1e8e85b298b97176359dd15731e0dc88


これらのファイルは次の版の安定版リリース時そちらに移されます。


- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@xxxxx
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<;pkg>
------>8------------>8------------>8------------>8------------>8-
--
Seiji Kaneko skaneko@xxxxx
---------------------------------------------------------

投稿者 xml-rpc : 2009年10月26日 20:59
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/89722
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。