2009年10月22日

[debian-users:53218] Re: バージョンの異なる同一ソフトが2つ同時に存在する不具合の解消方法について


 #最初から「pathfinderが使いたい」とか明確にしてもらった方が良かったような…


On Wed, 21 Oct 2009 19:07:47 +0900
Satoru Otsubo <trnsnt@xxxxx> wrote:
> 私もそのことは考えて、sidからwvstreamsを#apt-get sourceでダウンロードして、#dpkg -i によりインストールしたのですが、
> libwvdbus.so だったかが

> 含まれていませんでした。
> 本家からのwvstreams-4.6.1を自分で configure, make, make installすると、ちゃんと含まれています。

 debian/rules ファイルを見ましょう。--with-dbus=no が指定されていました。


> これはどういうことだろうかと考えていました。
> いつからかのバージンから本家のwvstreamsには、libwvdbus.soが含まれるようになったのに、
> debianのほうではまだその処理が行われていないのだろうかとか考えていました。

 dbus を wvstreams のソース中に以前のバージョンでは保持していたのですが、
 外部ライブラリの参照になっています。


 動くかどうかは不明ですが、Lenny で backport したパッケージを作って
 みたので置いておきます。

http://www.mithril-linux.org/~henrich/debian/package/pathfinder/

--
Regards,

Hideki Yamane henrich @ debian.or.jp/iijmio-mail.jp
http://wiki.debian.org/HidekiYamane


投稿者 xml-rpc : 2009年10月22日 10:16
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/89631
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。