2009年10月21日

[debian-users:53217] Re: バージョンの異なる同一ソフトが2つ同時に存在する不具合の解消方法について

On Wed, 21 Oct 2009 19:02:26 +0900
Satoru Otsubo <trnsnt@xxxxx> wrote:
こんばんは、芳賀です。
> (1) 全てを/opt/hogeにインストールするとしました。
(中略)
> /usr/local/lib/libwvdbus.so: undefined reference to `dbus_message_set_serial'
> /usr/local/lib/libwvdbus.so: undefined reference to `dbus_message_lock'
> /usr/local/lib/libwvdbus.so: undefined reference to `dbus_message_demarshal_bytes_needed'

> が表示されてしまいました。

てことは、wvstreams をビルドしたときに、/opt/hoge にインストールされた
dbus のライブラリが正常に検出されていない(よって、ちゃんとリンクされていない)
のに、wvstreams が正常にビルドされた「ように終了してしまった」か、インストール
したバージョンの dbus では、`dbus_message_set_serial'、`dbus_message_lock'、
`dbus_message_demarshal_bytes_needed' という三つの関数がサポートされて
いない、ということになるんでしょうか。はてさて...
--
Yasufumi Haga <yasufumi.haga@xxxxx>


投稿者 xml-rpc : 2009年10月21日 22:08
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/89597
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。