2009年10月18日

[debian-users:53195] [Translate] [SECURITY] [DSA 1913-1] New bugzilla packages fix SQLinjection

かねこです。
URL 等は Debian-security-announce メーリングリストの元記事を確認
ください。

------>8------------>8------------>8------------>8------------>8-
- ------------------------------------------------------------------------
Debian Security Advisory DSA-1913-1 security@xxxxx
http://www.debian.org/security/ Giuseppe Iuculano

October 17, 2009 http://www.debian.org/security/faq
- ------------------------------------------------------------------------

Package : bugzilla
Vulnerability : SQL インジェクション vulnerability
Problem type : リモート
Debian-specific: いいえ
Debian bug : 547132
CVE Id : CVE-2009-3165

Max Kanat-Alexander, Bradley Baetz, and Frédéric Buclin
の各氏により、ウェブベースのバグトラッキングシステム Bugzilla の
Bug.create ウェブサービス関数に SQL インジェクション脆弱性が発見されま
した。この欠陥を攻撃することにより、リモートの攻撃者が任意の SQL コマ
ンドを実行可能です。

安定版 (stable) ディストリビューション (lenny) では、この問題はバージ
ョン 3.0.4.1-2+lenny2 で修正されています。

旧安定版 (etch) にはこの問題の影響はありません。

テスト版ディストリビューション (squeeze) および不安定版ディストリビュ
ーション (sid) では、この問題は 近く修正予定です。

直ぐに bugzilla パッケージをアップグレードすることを勧めます。


アップグレード手順
------------------

wget url
でファイルを取得できます。
dpkg -i file.deb
で参照されたファイルをインストールできます。

apt-get パッケージマネージャを用いている場合には、本メールのフッタ記載の
行を sources.list に加えて、

apt-get update
を実行して内部データベースを更新し、
apt-get upgrade
によって修正されたパッケージをインストールしてください。

本メールのフッタ記載の設定を自ホストの設定に加えることにより、自動更新を
行うこともできます。


Debian GNU/Linux 5.0 alias lenny
- --------------------------------

Debian (stable)
- ---------------

安定版の更新は、alpha, amd64, arm, hppa, i386, ia64, mips, mipsel,
powerpc, s390 および sparc の各アーキテクチャで提供されています。
.
ソースアーカイブ:

http://security.debian.org/pool/updates/main/b/bugzilla/bugzilla_3.0.4.1-2+lenny2.dsc
Size/MD5 checksum: 1243 d2042a55019cb36fc55be54ccb1e21f6

http://security.debian.org/pool/updates/main/b/bugzilla/bugzilla_3.0.4.1-2+lenny2.diff.gz
Size/MD5 checksum: 69637 b4a57f2a01a0ac62657694874303399f
http://security.debian.org/pool/updates/main/b/bugzilla/bugzilla_3.0.4.1.orig.tar.gz
Size/MD5 checksum: 3954446 a5059f2d816d9675f7029146c2153a7a

アーキテクチャに依存しないパッケージ:


http://security.debian.org/pool/updates/main/b/bugzilla/bugzilla3_3.0.4.1-2+lenny2_all.deb
Size/MD5 checksum: 2146316 2cb2805efc33850f445bbfa1ad9d0a25

http://security.debian.org/pool/updates/main/b/bugzilla/bugzilla3-doc_3.0.4.1-2+lenny2_all.deb
Size/MD5 checksum: 762556 3475bb044582f909e90ba58ac7c5bbf4


これらのファイルは次の版の安定版リリース時そちらに移されます。


- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@xxxxx
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<;pkg>
------>8------------>8------------>8------------>8------------>8-
--
Seiji Kaneko skaneko@xxxxx
---------------------------------------------------------

投稿者 xml-rpc : 2009年10月18日 22:54
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/89491
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。