2009年10月18日

[debian-users:53192] Re: バージョンの異なる同一ソフトが2つ同時に存在する不具合の解消方法について

On Sun, 18 Oct 2009 03:53:00 +0900
mizuhara@xxxxx (水原 文) wrote:

芳賀と申します。

> 水原と申します。
>
> 何が問題なのかよく理解できなかったのですが、バイナリが ELF 形式だとす

> れば、リンカに --rpath オプションを指定すれば解決できませんか?

私も、Vine 4.2 を使っていたとき、このディストリビューション付属のgtk+
ではなく、GTK+ 2.14.x を使おうと思い、glib、atk、...、gtk+ をソース
からビルドした際、

http://www.linux.or.jp/JF/JFdocs/Program-Library-HOWTO/shared-libraries.html#AEN132

を参考に、"--rpath" を使いました。このときは "rpath" やら "Wl" やら
なんやらのオプションを環境変数 LDFLAGS に設定しました。
--
Yasufumi Haga <yasufumi.haga@xxxxx>


投稿者 xml-rpc : 2009年10月18日 09:21
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/89487
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。