2009年10月13日

[debian-users:53180] [Translate] [SECURITY] [DSA 1907-1] New kvm packages fix severalvulnerabilities

かねこです。
URL 等は Debian-security-announce メーリングリストの元記事を確認
ください。

------>8------------>8------------>8------------>8------------>8-
- ------------------------------------------------------------------------
Debian Security Advisory DSA-1907-1 security@xxxxx
http://www.debian.org/security/ Giuseppe Iuculano

October 13, 2009 http://www.debian.org/security/faq
- ------------------------------------------------------------------------

Package : kvm
Vulnerability : 複数の欠陥
Problem type : ローカル (リモート)
Debian-specific: いいえ
Debian bugs : 509997 548975
CVE Ids : CVE-2008-5714 CVE-2009-3290


完全仮想化システム kvm に、複数の問題が発見されました。The Common
Vulnerabilities and Exposures project は以下の問題を認識しています。

CVE-2008-5714

Chris Webb さんにより、KVM の VNC パスワードを制限する処理に境界を 1 誤
るバグがあり、パスワードが 7 文字に制限されていることが発見されました。
この欠陥により、本来 8 文字を意図していた VNC パスワードが 7 文字に制限
されるため、リモートの攻撃者からのパスワード推定が多少容易になります。

CVE-2009-3290

KVM の kvm_emulate_hypercall 関数がリング 0 からの MMU ハイパーコールを制
限していないため、ローカルのゲスト OS ユーザからサービス拒否攻撃 (ゲスト
カーネルのクラッシュ) や、ゲストのカーネルメモリの読み書きが可能であるこ
とが発見されました。


安定版 (stable) ディストリビューション (lenny) では、これらの問題はバージ
ョン 72+dfsg-5~lenny3 で修正されています。

旧安定版 (etch) には kvm パッケージは収録されていません。

テスト版ディストリビューション (squeeze) では、これらの問題は近く修正予定
です。

不安定版 (unstable) ディストリビューション (sid) では、これらの問題はバー
ジョン 85+dfsg-4.1 で修正されています。

直ぐに kvm パッケージをアップグレードすることを勧めます。


アップグレード手順
------------------

wget url
でファイルを取得できます。
dpkg -i file.deb
で参照されたファイルをインストールできます。

apt-get パッケージマネージャを用いている場合には、本メールのフッタ記載の
行を sources.list に加えて、

apt-get update
を実行して内部データベースを更新し、
apt-get upgrade
によって修正されたパッケージをインストールしてください。

本メールのフッタ記載の設定を自ホストの設定に加えることにより、自動更新を
行うこともできます。


Debian GNU/Linux 5.0 alias lenny
- --------------------------------

Debian (stable)
- ---------------

安定版の更新は、alpha, amd64, arm, hppa, i386, ia64, mips, mipsel,
powerpc, s390 および sparc の各アーキテクチャで提供されています。

ソースアーカイブ:

http://security.debian.org/pool/updates/main/k/kvm/kvm_72+dfsg-5~lenny3.dsc
Size/MD5 checksum: 1349 da207d5f42ab45ed3956be5fcb6ad685
http://security.debian.org/pool/updates/main/k/kvm/kvm_72+dfsg-5~lenny3.diff.gz
Size/MD5 checksum: 41138 f28b640e60392636399873e99b6cc5e3
http://security.debian.org/pool/updates/main/k/kvm/kvm_72+dfsg.orig.tar.gz
Size/MD5 checksum: 3250251 899a66ae2ea94e994e06f637e1afef4a

アーキテクチャに依存しないパッケージ:

http://security.debian.org/pool/updates/main/k/kvm/kvm-source_72+dfsg-5~lenny3_all.deb
Size/MD5 checksum: 158242 8cee5a68dadbbceecdac6330b69fa59f

amd64 architecture (AMD x86_64 (AMD64))

http://security.debian.org/pool/updates/main/k/kvm/kvm_72+dfsg-5~lenny3_amd64.deb
Size/MD5 checksum: 1099546 5009415dc4927800b33249ca31d8a651

i386 architecture (Intel ia32)

http://security.debian.org/pool/updates/main/k/kvm/kvm_72+dfsg-5~lenny3_i386.deb
Size/MD5 checksum: 1030530 313f1a0d91889bf167c4e1aaf57a027d


これらのファイルは次の版の安定版リリース時そちらに移されます。


- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@xxxxx
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<;pkg>
------>8------------>8------------>8------------>8------------>8-
--
Seiji Kaneko skaneko@xxxxx
---------------------------------------------------------

投稿者 xml-rpc : 2009年10月13日 21:16
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/89420
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。