2009年9月18日

[debian-users:53005] Re: RubyGems パッケージについて

森脇です。

rubyとrubygemsをメンテしています。

okkez さんは書きました:
> rubygems1.9.1 というパッケージ名で RubyGems の 1.3.5 が入ります。
> Ruby1.9.1 をソースコードからコンパイルしてインストールした場合は RubyGems は 1.3.1 が入ります。
> # Ruby の trunk からインストールした場合でも RubyGems は 1.3.4 です。

>
> 最新のものが入るのはうれしいのですが、これはどういう事情でそうなっているのでしょうか?
> 単にパッケージメンテナの方針でそうなる / なっている、ということでしょうか?

RubyとRubygemsとでは、アップストリームのリリース頻度が異なります(経験上Rubyのほ
うが長い)。Rubygemsのほうが要望などが多いため、容易にアップデートできるように、
分けて管理しています。

ところで、Ruby1.9.1をソースからビルドする事情を教えていただけると嬉しいです
(Debianのバイナリに不便な点があるのでしょうか)。

では。

--
Daigo Moriwaki
daigo at debian dot org
beatles at sgtpepper dot net


投稿者 xml-rpc : 2009年9月18日 20:08
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/88708
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。