2009年7月31日

[debian-users:52746] Lenny on Dell Dimension 4700Cで音が出ない

守屋と申します.

 2年ぶりぐらいにdebianをインストールしたので知識が初心者レベルに戻っ
てしまいました.拙い質問ですがご指導いただければ幸いです.

 中古で購入したDell Dimension 4700C(CeleronD 325)に先日Lennyをイン
ストールしたのですが,KDE,GNOMEいずれでも音が全く出なくて困っています.

 実は2年ほど前にやはり中古で購入したDimension 4700C(こちらはPentium4
520)にはEtchをインストールしてその後Lennyにもdist-upgradeしているの
ですが,こちらはEtch当時もLennyにアップグレード後も問題なく音---起動時
やパッケージ作動時などのイベント音しか確認していませんが---が出ています.

 CPUが違うだけでマザーボードもサウンドコントローラ(オンボード)も同
じ機種にLennyをインストールして,片や音が出て片や出ないという現象が解
決できずお尋ねする次第です.
http://www1.jp.dell.com/content/topics/segtopic.aspx/pressoffice/2004/040928?c=jp&l=jp&s=corp

 自分が今確認できていることは以下の通りです.
 足りない情報がありましたらご指摘下さい.

■サウンドコントローラはAnalog Devices AD 1980 AC'97 Codec.lspciで確認
するとどちらのマシンでも「Intel Corporation 82801FB/FBM/FR/FW/FRW(ICH6
Family) AC'97 Audio Controller」ときちんと表示されます.

 音が出ないCeleronマシンでは,

■KDEでKmixを起動するとインジケータが全く表示されず小さなブランクとメ
ニューバーだけの無意味なアプリケーション画面が立ち上がる.
■alsamixerguiを起動すると”function snd_ctl_open failed for default: No
such device”エラーが出て立ち上がらない.
■Konsoleでalsamixerを起動すると通常のコントロール画面が現れる.しかし
それで種々音量を上下したりミューとをon/offしても一向に音は出ない.
■artsbuilderを観察すると,コントロールセンターから「サウンドテスト」を
行うとartsbuilder上ではインジケータが音に合わせて(?)上下する.

といった感じです.

 音が出るPentiumマシンではKmixもalsamixerguiも問題なく動作します.


 サウンドカードはちゃんと認識されているのでそれより上のレイヤーである
ことは分かるのですが,具体的にどうすればよいのかgoogleで3日ほど検索し
まくったのですがよい解決法に出会えませんでした.

 どう問題を切り分けて,どう攻めればよいのか,ご指導いただければ幸いです.

--
______________________________________________
|
| +-----+
| |---$0|
| |-=-=-| 守屋章成 Moriya Akinari
| |-=-=-| moriya.akinari@xxxxx
| +-----+
|______________________________________________


投稿者 xml-rpc : 2009年7月31日 23:06
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/87153
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。