2009年6月26日

[debian-users:52591] [Translate] [SECURITY] [DSA 1824-1] New phpmyadmin packages fix severalvulnerabilities

かねこです。
URL 等は Debian-security-announce メーリングリストの元記事を確認
ください。

------>8------------>8------------>8------------>8------------>8-
- ------------------------------------------------------------------------
Debian Security Advisory DSA-1824-1 security@xxxxx
http://www.debian.org/security/ Thijs Kinkhorst

June 25, 2009 http://www.debian.org/security/faq
- ------------------------------------------------------------------------

Package : phpmyadmin
Vulnerability : 複数
Problem type : リモート
Debian-specific: いいえ
CVE Id(s) : CVE-2009-1150 CVE-2009-1151

MySQL をウェブインターフェースで管理するツール phpMyAdmin に、リモート
から攻撃可能な複数の問題が発見されました。The Common Vulnerabilities
and Exposures project は以下の問題を認識しています。

CVE-2009-1150

export ページにクロスサイトスクリプティング脆弱性があり、ユーザに対す
る細工したクッキーを設置できる攻撃者が任意のウェブスクリプトや HTML
を挿入可能です。

CVE-2009-1151

スタティックコードインジェクション脆弱性のため、setup.php スクリプト
を使って phpMyAdmin にリモートの攻撃者が任意のコードを挿入可能です。
このスクリプトは Debian の通常環境では Apache 認証で保護されています。
但し、最近のワームがこの欠陥を攻撃しているので、何らかの理由で
setup.php を露出した設定に対する保護も提供します。

旧安定版 (oldstable) ディストリビューション (etch) では、これらの問題
はバージョン 2.9.1.1-11 で修正されています。

安定版 (stable) ディストリビューション (lenny) では、これらの問題はバ
ージョン 2.11.8.1-5+lenny1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、これらの問
題はバージョン 3.1.3.1-1 で修正されています。

直ぐに phpmyadmin パッケージをアップグレードすることを勧めます。


アップグレード手順
------------------

wget url
でファイルを取得できます。
dpkg -i file.deb
で参照されたファイルをインストールできます。

apt-get パッケージマネージャを用いている場合には、本メールのフッタ記載の
行を sources.list に加えて、

apt-get update
を実行して内部データベースを更新し、
apt-get upgrade
によって修正されたパッケージをインストールしてください。

本メールのフッタ記載の設定を自ホストの設定に加えることにより、自動更新を
行うこともできます。


Debian GNU/Linux 4.0 alias etch
- -------------------------------

ソースアーカイブ:

http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.9.1.1-11.diff.gz
Size/MD5 checksum: 55496 8450833432ad5375f2f2ee1e46e1f2ed

http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.9.1.1.orig.tar.gz
Size/MD5 checksum: 3500563 f598509b308bf96aee836eb2338f523c
http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.9.1.1-11.dsc
Size/MD5 checksum: 1021 c1bf0fcab92a24bb1098741af970bf17

アーキテクチャに依存しないパッケージ:

http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.9.1.1-11_all.deb
Size/MD5 checksum: 3603256 de0e342fbad8c9ee88c7d7d146a8d570

Debian GNU/Linux 5.0 alias lenny
- --------------------------------

ソースアーカイブ:


http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.11.8.1.orig.tar.gz
Size/MD5 checksum: 2870014 075301d16404c2d7d58216efc14f7a50

http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.11.8.1-5+lenny1.diff.gz
Size/MD5 checksum: 61185 88bd2878a486d156bb38a34741709d14

http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.11.8.1-5+lenny1.dsc
Size/MD5 checksum: 1547 337922cac201ab2200a1ee11966563c8

アーキテクチャに依存しないパッケージ:


http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.11.8.1-5+lenny1_all.deb
Size/MD5 checksum: 2881674 030f63ceeb7568f2082ea578b1a7eac4


これらのファイルは次の版の安定版リリース時そちらに移されます。


- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@xxxxx
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<;pkg>
------>8------------>8------------>8------------>8------------>8-
--
Seiji Kaneko skaneko@xxxxx
---------------------------------------------------------

投稿者 xml-rpc : 2009年6月26日 22:48
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/86204
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。