2009年6月 9日

[debian-users:52557] live-magic(proposed-update版)_依存関係エラー

こんにちは、mejikoです。本来はBTSに報告すべきかと思いますが、よくわから
ないのでここに投稿させてもらいます。すいませんが、よろしくお願いします。

今日、proposed-updatesの更新があったのですが、その際、未解決の依存関係で
「live-magic」がアップデートできなくなりました。

Debianはのバージョンは5.0.1、安定版を使用しています。リポジトリは、オ
フィシャルで登録できるリポジトリ(proposed-updatesも含む)全てと、サード

パーティでは、バックポート、DebianMultimediaを追加しています。

現時点では最新の状態です。なお、それ以外のアップデートで
「system-tools-backends」がありましたが、こちらは正常にアップデートする
ことができました。ちなみにこちらのバージョンの変化は次の通りです。
(Synapticのログです)


以下のパッケージがアップグレードされました:
system-tools-backends (2.6.0-2lenny2) to 2.6.0-2lenny3


一旦live-magicを「完全削除指定」でアンインストールし、もう一度
「Synaptic」で「live-magic」をインストールしようとしたところ、以下のエ
ラーが出ました。


〈Synaptic〉

live-magic:
依存 python-support (>=0.90.0) しかし 0.8.4 をインストールする必要があ
ります


確かにその「python-support」のバージョンは「0.8.4」でした。

また、コマンドライン「apt-get」及び「aptitude」からやってみましたが、次
のような結果が出ました。


〈apt-get〉

canon@xxxxx:~$ sudo apt-get install live-magic
canon@xxxxx Password:
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
インストールすることができないパッケージがありました。おそらく、あり得
ない状況を要求したか、(不安定版ディストリビューションを使用しているの
であれば) 必要なパッケージがまだ作成されていなかったり Incoming から移
動されていないことが考えられます。
以下の情報がこの問題を解決するために役立つかもしれません:

以下のパッケージには満たせない依存関係があります:
live-magic: 依存: python-support (>= 0.90.0) しかし、0.8.4 はインス
トールされようとしています
E: 壊れたパッケージ


〈aptitude〉

canon@xxxxx:~$ sudo aptitude install live-magic
canon@xxxxx Password:
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
拡張状態情報を読み込んでいます
パッケージの状態を初期化しています... 完了
タスクの記述を読み込んでいます... 完了
以下のパッケージは依存関係が壊れています:
live-magic
更新: 0 個、新規インストール: 1 個、削除: 0 個、保留: 0 個。
62.4kB のアーカイブを取得する必要があります。展開後に 350kB のディスク領
域が新たに消費されます。
以下のパッケージには満たされていない依存関係があります:
live-magic: 依存: python-support (>= 0.90.0) [0.8.4 が既にインストール
済みです]
以下のアクションでこれらの依存関係の問題は解決されます:

以下のパッケージをインストールする:
live-magic [1.5 (stable)]

スコアは -9920 です

この解決方法を受け入れますか? [Y/n/q/?]

この解決方法を受け入れてインストールもためしてみましたが、やはりそのあと
の「dist-upgrade」でアップグレードすることはできず、アップデートマネー
ジャーでアップデートしようとすると、スマートアップデートするか聞いてきま
した。一応スマートアップデートを選択しましたが「live-magic」がグレーアウ
トになっており、アップデートできません。

そのため現在は「live-magic」は削除しています。


どうすればlive-magicをインストール・アップデートすることができますでしょ
うか。
また、バグ登録は日本語ではできませんか?(英文を打つのは苦手です……。英語
はあらかた読めるのですが……)

ご存知の方はこ教示よろしくお願いします。

投稿者 xml-rpc : 2009年6月 9日 16:56
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/85730
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。