2009年5月27日

[debian-users:52504] Re: OpenOfficeの縦書き問題

長南です。

お節介かもしれませんが、なんだか勘違いなさっているようなので、
書いておきます。それとも、わたしが勘違いしているのだろうか。

canon さんのメールより [debian-users:52490]
>
> > 当方ではこんな具合でした。

> >
> > $ sudo aptitude -t lenny-backports install openoffice.org
> > パッケージリストを読み込んでいます... 完了
> >
> > ---- (省略) ----
> >
> > 以下のパッケージは依存関係が壊れています:

> 実は「依存関係が壊れる」という文言に少々不安なところがあったため「この解
> 決方法を受け入れますか?」で、nを選択しました。しかし何度も同じ質問を繰
> り返す(パッケージは違う)ので、無理矢理「Ctrl+C」で中止しました。確か
> 「スコアは○○です」とかもでたような。

aptitude -t lenny-backports install openoffice.org の出力の全文を
添付ファイルにした方がよかったかもしれません (script で記録した
ファイルがあんまり長いので、一部だけ引用して済ませたのですけれど)。

出力されるメッセージが言っているのは、要するにこういうことでしょう。
backports から openoffice のパッケージ群を入れると、(たぶん一時的に)
依存関係に齟齬が生じる (それがずらずらっと出力されるわけです)。
だから、apt や aptitude はこういうふうにそれを解決しますよ。

以下のアクションでこれらの依存関係の問題は解決されます:

以下のパッケージを更新する:
dictionaries-common [0.98.12 (stable, now) -> 1.0.0~bpo50+1 (lenny-backports)]
openoffice.org-base [1:2.4.1+dfsg-1 (stable, now) -> 1:3.0.1-11~bpo50+2
(lenny-backports)]
openoffice.org-base-core [1:2.4.1+dfsg-1 (stable, now) -> 1:3.0.1-11~bpo50+2
(lenny-backports)]
openoffice.org-calc [1:2.4.1+dfsg-1 (stable, now) -> 1:3.0.1-11~bpo50+2
(lenny-backports)]
---- (中略) ----
スコアは 798 です
この解決方法を受け入れますか? [Y/n/q/?]y
以下の新規パッケージがインストールされます:

ですから、この後に提示される「インストールされる新規パッケージ」、
「削除されるパッケージ」、「更新されるパッケージ」をよく見て (とりわけ
「削除されるパッケージ」に注意ですね)、大丈夫そうだったら、apt (あるいは
aptitude) の解決法を信用して、backports のパッケージををインストール
してもよいのではないでしょうか。実際にダウンロードとインストールが
始まる前に、もう一度「先に進みますか? [Y/n/?]」と訊いてくるのですし。

まあ、やるやらないは自己責任ですし、ご自由ですけれど。

--
長南洋一


投稿者 xml-rpc : 2009年5月27日 22:34
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/85461
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。