2008年7月22日

[debian-users:50769] Re: aptitudeがインストールできない

冬猫様、度々誠にありがとうございます。
状況は下のようなsorces.listと、メッセージでした。
良いのかどうか、分かりませんが、kept backされたものをひとつずつ、#aptitude
install *****としていったところ、何とかできたようです(問題があるようでしたら
お願いいたします)。

只、sambaで、直近のファイルをバックアップしていなかった為、文字化けしてしま
いました。

smbfnconv を使用できるように、インストールまで行きません。
また、別にスレッドを立てるかも知れませんが、その時はどうかよろしくお願いいた
します。

deb http://ftp.riken.jp/Linux/debian/debian/ sarge main contrib non-free

# apt-get update
Get:1 http://ftp.riken.jp sarge/main Packages [4523kB]
Get:2 http://ftp.riken.jp sarge/main Release [98B]
Get:3 http://ftp.riken.jp sarge/contrib Packages [73.7kB]
Get:4 http://ftp.riken.jp sarge/contrib Release [101B]
Get:5 http://ftp.riken.jp sarge/non-free Packages [76.6kB]
Get:6 http://ftp.riken.jp sarge/non-free Release [102B]
Fetched 4673kB in 33s (140kB/s)
Reading Package Lists... Done

# apt-get upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages have been kept back:
abiword-common apache apache-common apache-ssl bind9 bind9-host dnsutils
file gdm
gnome-applets gnome-control-center gnome-core gnome-panel gnome-panel-data
gnome-session
gnome-terminal gnome-utils gs kcoloredit kdelibs3-bin kdepasswd kdm kfind
kghostview
kiconedit kruler ksnapshot kugar kview lesstif1 libcupsys2 libisccc0
libisccfg0 libnspr4
libnss3 libpgtcl lwresd mozilla mozilla-browser mozilla-mailnews
mozilla-psm mutt pgaccess
postgresql postgresql-client rep-gtk rep-gtk-gnome samba samba-common
sawfish-gnome
smbclient smbfs swat uw-imapd xbase-clients xlibmesa3 xlibs xterm
0 upgraded, 0 newly installed, 0 to remove and 58 not upgraded.

# aptitude -f --with-recommends dist-upgrade
Reading Package Lists... Done
Building Dependency Tree
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
E: Unable to correct problems, you have held broken packages.
E: Unable to correct dependencies, some packages cannot be installed
-----

> > 只、今の段階でも、apacheなどがkept back されているので、apacheなど、この
まま
> > で良いのか、どうやったらアップできるのか、恐れ入りますが、ご教示頂ければ
と存
> > じます。
>
> リリースノートの続きをやってみてはいかがでしょう。
>
> kept backされる場合、たいていは依存関係の問題でしょう。ですが、
> dist-upgradeすると、パッケージを削除してでも整合性を取ろうと
> しますので、あまりkept backされないような気がします。
>
> まあ、出てきたメッセージを提示していただかないことには、神降臨を
> 待つばかりになってしまいます。
> --
> 喜瀬“冬猫”浩
>
>

投稿者 xml-rpc : 2008年7月22日 19:31
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/75519
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。