2008年7月16日

[debian-users:50749] Re: etch-custom-0720.isoについて

武藤@Debianぷろじぇくとです。

At Wed, 16 Jul 2008 12:17:13 +0900,
Satoru Otsubo wrote:
> そこで、SATAのHDD、Core 2 duoのCPUあたりは、kernel image を 2.6.21にするだけで、
> 利用できたのではと思いました。

カーネル2.6.21にこだわる理由がいまいちわからないのですが、

インストーラに追加した新機能がないとはいえ、デバイスドライバ
面ではいろいろ修正が加えられているので、新しいカーネルを使った
ほうが一般に良いでしょう。

> そして、2.6.21にローカルセキュリティホールがあるとすれば、kernel を
> http://www.kernel.org/pub/linux/kernel/v2.6/
> あたりを用いて、更にバージョンアップすればよいのではと思いました。
> これだと問題ないのでしょうか。

まぁ問題ないですけど手間がバカバカしくないですか?

> なお、Debian で提供されている 修正済 Linux カーネルパッケージを利用する
> という意味がよくわかりません。

修正済みというか、Debianパッケージのカーネルには独自のカーネル変更が
入っていることがあります。ただ2.6.21は私がkernel.orgカーネルソースから作った
パッケージだったと思うので、これには独自の変更は入っていません。2.6.25は
Debianパッケージのものなので、いくつか変更が入っているはずです。

> $ aptitude search linux-image
> を用いて表示される
> linux-image-2.6.25-2-686等は、
> linux-image-2.6.25-2-686 - Linux 2.6.25 image on PPro/Celeron/PII/PIII/P4
> 等となっており、Core 2 duoに使えるようには表示されていません。

-686でC2Dを利用できます。ただC2Dの64ビット機能サポートも使いたいなら
-amd64をインストールするのがよいでしょう。
--
武藤 健志@ kmuto @ kmuto.jp
Debian/JPプロジェクト (kmuto@xxxxx, kmuto@xxxxx)
株式会社トップスタジオ (kmuto@xxxxx)
URI: http://kmuto.jp/ (Debianな話題など)


投稿者 xml-rpc : 2008年7月16日 12:53
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/75304
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。