2008年4月27日

[debian-users:50444] [Translate] [SECURITY] [DSA 1559-1] New phpgedview packages fix cross site scripting

代打中野です。
URL 等は Debian-security-announce メーリングリストの元記事を確認ください。

------------------------------------------------------------------------
Debian Security Advisory DSA-1559-1 security@xxxxx
http://www.debian.org/security/ Thijs Kinkhorst
April 27, 2008 http://www.debian.org/security/faq
------------------------------------------------------------------------


Package : phpgedview
Vulnerability : 入力のサニタイズが不十分
Problem type : リモート
Debian-specific: いいえ
CVE Id(s) : CVE-2007-5051
Debian Bug : 443901

家系図データへのオンラインアクセスを可能とするアプリケーション
phpGedView において、入力データのサニタイズが十分でなく、クロス
サイトスクリプティング脆弱性が生じうることがわかりました。

安定版 (stable) ディストリビューション (etch) では、これらの問題は
バージョン 4.0.2.dfsg-3 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、これらの問題は
バージョン 4.1.e+4.1.1-2 で修正されています。

直ぐに phpgedview パッケージをアップグレードすることを勧めます。

アップグレード手順
------------------

wget url
でファイルを取得できます。
dpkg -i file.deb
で参照されたファイルをインストールできます。

apt-get パッケージマネージャを用いている場合には、本メールのフッタ記載の
行を sources.list に加えて、

apt-get update
を実行して内部データベースを更新し、
apt-get upgrade
によって修正されたパッケージをインストールしてください。

本メールのフッタ記載の設定を自ホストの設定に加えることにより、自動更新を
行うこともできます。


Debian GNU/Linux 4.0 (愛称 etch)
--------------------------------

ソースアーカイブ:

http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview_4.0.2.dfsg.orig.tar.gz
Size/MD5 checksum: 6181964 73b1f051f01dcd6520a044badaa40fe6
http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview_4.0.2.dfsg-3.diff.gz
Size/MD5 checksum: 7845 0ae3d02bf2f9bfecac01bfbb98e16b53
http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview_4.0.2.dfsg-3.dsc
Size/MD5 checksum: 1053 30d7415d993b4034f44fdfcd9bf9d998


アーキテクチャに依存しないパッケージ:

http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview-themes_4.0.2.dfsg-3_all.deb
Size/MD5 checksum: 876616 0745d130e09318bd72790028db6a943d
http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview-places_4.0.2.dfsg-3_all.deb
Size/MD5 checksum: 2270996 ce02af3e71b958d0fd3f72c1eea9eca4
http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview_4.0.2.dfsg-3_all.deb
Size/MD5 checksum: 1215452 dff7649b79e3f32ee6868839cd3c4c68
http://security.debian.org/pool/updates/main/p/phpgedview/phpgedview-languages_4.0.2.dfsg-3_all.deb
Size/MD5 checksum: 1821112 1b004f9221d532a1e07eb242bdd13ba1


これらのファイルは次の版の安定版リリース時そちらに移されます。

---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@xxxxx
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<;pkg>

投稿者 xml-rpc : 2008年4月27日 18:51
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/72594
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。