2007年12月17日

[debian-users:49894] Re: ATOKXの設定後、起動しなくなった

鍋太郎@ATOKX->ATOKX3ユーザです。

いくつか気になったところにコメントします。
確認してみてください。

On Mon, 17 Dec 2007 15:16:45 +0900
KUSUMIZU CHIGUSA <nonnonyonyon@xxxxx> wrote:

> sargeでATOKX for Linuxをインストールしようと思い、以下の手順を行いました。
>
> 1. iiimf-htt-server, iiimf-htt-csconv, iiimf-htt-xbe, libiiimcf2のインストール(これらは、必要あるなしにかかわらずとりあえず入れてみました。)

ここ怪しいですね。

> 2.ATOKXのCDよりファイルを/tmp/atokxにコピーし、インストール(パッチはインストール時にインターネットから取得)

これはatokxパッケージを使用したのですよね。

> 3.使用するユーザの.xsessionを以下のように書き換え(追加:○ コメントアウト:●)
>
> # ---- language-env DON'T MODIFY THIS LINE!# 以下のシェル変数によって、動作が変わります。# TERMILAL KIDOU KAIJOTERMINAL_EMULATOR = none # $TERMINAL_EMULATOR# $WINDOW_MANAGERLANG=ja_JP.eucJPexport LANGPATH=$HOME/bin:$PATH#===================================# 日本語入力 (XIM) の設定
> # XIM サーバーを起動する●#if type kinput2 &> /dev/null ; then●# kinput2 -canna &●#fi●#XMODIFIERS=@im=kinput2 ; export XMODIFIERS○# ATOKX NO SETTEI○/usr/lib/atokx/im/locale/ja/atokserver/atokx_client○XIM=htt○XMODIFIERS=@im=$XIM○export XMODIFIERS#===================================

改行がごちゃごちゃになってますが、私が行った旧設定と同じに見えます。
次の再起動で止まることの原因にはならないと思います。

> 4.再起動
>
> 再起動中に、「Starting Internet/Internet Input Method server: htt-server」と出たところで止まってしまいます。他の方のBlog等を参考にしながら進めましたが、同じような症状が発生している方がおらず、また端末が起動しなくなり困っています。何卒ご教授お願いいたします。

最近のatokxパッケージには、
Conflicts: iiimf-htt-server, iiimf-server
とあるので、それらと同時にはインストールできません。
おそらく本質的に競合する(atokxってhttサーバですよね)と思いますので、
(これらは、必要あるなしにかかわらずとりあえず入れてみました。)
がまずいのではないかな、と思います。

私ならiiimf-htt-serverをまず消してみます。

--
+--------------------------------------------------------+
倉澤 望(鍋太郎)
KURASAWA Nozomu (nabetaro) <nabetaro @ caldron.jp>
GnuPG FingerPrint:
C4E5 7063 FD75 02EB E71D 559B ECF6 B9D2 8147 ADFB
+--------------------------------------------------------+

投稿者 xml-rpc : 2007年12月17日 16:24
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/67725
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。