2007年12月 1日

[debian-users:49835] Re: evince で日本語フォントが化ける件

On Sat, 1 Dec 2007 02:05:09 +0900
Kobayashi Noritada <nori1@xxxxx> wrote:
> ftpmasters の問題ではなく、ソフトウェアが non-free であれば Debian と
> しては main に入れるのは reject せざるをえないと思います。

 ん、main に入れろ、と言う話になっていたのでしたっけ?
 おっかけきれてませんのでどこか教えてください。


> バグ報告には evince 0.8.x ではきちんと表示された、とありますが、これは
> どのような環境においてでしょうか? xpdf-japanese や cmap-adobe-japan1
> など non-free のパッケージをまったく入れていなかった自分の環境では、日
> 本語は (フォントが埋め込まれているもの以外は) まったく表示されなかった
> ので、個人的には状況は悪くなったとは感じていないので……。

 cmap 関連の non-free なものを入れていたと思います。
 で、0.8.x ではその設定状態でいけたものがアップグレードしたら突然
 仕様が変わって代替パッケージが存在していない状況ですから、悪化だと
 思います。

> > よく分かりませんが、もしmainがだめならnon-freeにpoppler-dataがアップ
> > されるのを待つのでしょうか?
> >
> > 変更禁止なだけですので、non-freeはOKのようです。
>
> 結局のところ、xpdf では non-free の cmap-adobe-japan1 が必要になり、
> xpdf ベースの poppler ではやはり non-free の poppler-data が必要、と解
> 釈していますが、それでよいのでしょうか (きちんと調べていないので間違っ
> ていたら指摘してください)? この問題の原因は結局のところ cmap データが
> Adobe に著作権があって改変不可能だということ[1]にあると考えています。

 大体あっています。細かいことを言えば、cmap データが adobe に著作権が
 あるのは改変不可な理由ではなく、著作権者である adobe が改変不可をうた
 っていることが問題なんですよね。つまり adobe さんがもう少し許諾条件を
 考えていただければなぁ、という話ですね。(またはマッピングデータだけ
 なら特別許諾を必要としないという解釈が成り立つかどうか、ですかね)


> しかしドライバやコーデックならともかく、日本語の PDF を見る環境まで
> non-free 依存というのはちょっと辛いので、できれば lenny リリースの前ま
> でにどうにかできないかと個人的に思案しているところです。何かいい解決策
> はないのでしょうか。
>
> [1] http://ukai.org/wiliki/wiliki.cgi?cmap%CC%E4%C2%EA

 真っ正面な所としては、adobe さんとの折衝をして許諾を確認する、でしょうか。


投稿者 xml-rpc : 2007年12月 1日 17:14
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/67075
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。