2005年1月 4日

[debian-users:42292] gs-esp の フォント設定


すがのです。
正月はまったりと年末に買ったプリンタの設定をして過ごしています。

それで気がついたのですが、CUPSが利用しているgs-espでは、「〜」という文
字が表示されないようです。
印刷でも出てきませんし、 gs-esp hoge.ps とやってXに表示させても出てき
ません。

直感的にこれはフォントのエンコーディングの問題かな、と思って gs-esp の

利用するフォントを変更してみようと思ったのですが、あちこちドキュメント
をあさったり検索してみたりしても変更方法が見付かりません。
そもそもどのフォントを利用してるのかも把握できませんでした。
/etc/vfontcapで変更できるのかと思ったのですが、これもgs-jaには効果があっ
てもgs-espには無いようです。

どなたかgs-espのフォント設定の仕方が書いてある文書等ご存知ありませんか?

環境は少々複雑なのですが、woodyベースにbackports.orgのcupsysと、sidの
gs-espをビルドしなおしたものを入れてます。
プリンタドライバはEPSONのPIPSを、debian上でrpm構築後alienしたものを、
cups版lpr版共々 --foce-orverwrite で突っ込んであります。

ii cupsys 1.1.20final-12 Common UNIX Printing System(tm) - server
ii cupsys-bsd 1.1.20final-12 Common UNIX Printing System(tm) - BSD comman
ii cupsys-client 1.1.20final-12 Common UNIX Printing System(tm) - client pro
ii libcupsys2 1.1.20final-12 Common UNIX Printing System(tm) - libs
ii libcupsys2-dev 1.1.20final-12 Common UNIX Printing System(tm) - developmen
ii gs-esp 7.07.1-9 The Ghostscript PostScript interpreter - ESP
ii pipsg900 2.6.2-3 EPSON Stylus PX-G900 用のPhoto Image Print S
ii pipsg900-cups 2.6.2-3 EPSON PX-G900 用の Photo Image Print System

この環境のせいかとも思ったのですが、別のsid環境のgs-espでもpsファイル
を表示させてみるとやはり「〜」が表示されてないので、おそらく関係ないと
思います。

--
狐志庵
Sugano Yoshihisa(E) <mailto:koshian@xxxxx>
Website: < http://www.misao.gr.jp/~koshian/>;
PGP fingerprint [6367 2352 3995 214E B954 A1FE 33D9 C918 606F 7C15]

投稿者 xml-rpc : 2005年1月 4日 01:37
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/15485
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。