2004年11月 8日

[debian-users:41922] Re: 【解決】CGIでの画像表示について

お世話になっています。
早川@北信<hayakawa@xxxxx>です

MasamiOhkubo <debizoh@xxxxx> さん
メールありがとうございます。
『[debian-users:41921] Re: 【ご質問】CGIでの画像表示について』
に対するご返事です。ご確認をお願いいたします。

> 大久保です。
早川です。

どうも素早いRESありがとうございます。
お忙しい所ありがとうございます。

> おそらく推測するには
> 「cgi-bin上で画像等が表示できない」
> なんだろうと思います。
御意!その通りです。

> 1.ScriptAliasにてcgi-binディレクトリに対してcgi実行許可を与えている
> 2.そのcgi-binに対し画像を設置している
まさしくおっしゃる通りです。

> であれば、そのScriptAliasのディレクトリであるcgi-binでは「全てがcgiス
> クリプト」として扱われるため、画像等、cgi以外のものは一切表示できませ
> ん。
なるほど!

> Apacheのドキュメントをどうぞ... v
> http://httpd.apache.org/docs-2.0/ja/mod/mod_alias.html#scriptalias
> http://httpd.apache.org/docs-2.0/ja/howto/cgi.html
参考にさせていただきました。

> 対処方法は
> 1.cgi-binをScriptAliasで設定するのではなく、Aliasにする
> 2.その上でcgi実行ができるようにExecCGIオプションを該当ディレクトリに付
> 加する。
↑の設定で画像表示が難なく出来るようになりました。
具体的に申しますと
【http.conf編集】
ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
 ◎↑となっている部分をコメントアウトしまして

 ◎↓のように書き換えました。(こんなので良いのかな?)
#ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
Alias /cgi-bin/ /usr/lib/cgi-bin/

 設定保存後、

【apache再起動】
$ sudo /etc/init.d/apache stop
$ suto /etc/init.d/apache start

上記にて、無事画像が表示されるようになりました。
ありがとうございました。

> が..簡単かもしれませんが、他にもいくつか方法は考えられます。
> とりあえず、ScriptAliasなのかどうなのかがカギです。
ズバっとこちらの状況を判断いただいているので、なにやら気持ちいい
ですね(^^;)

> おそらく状況を伺うに100% ScriptAliasだろうとは思いますが,imgのパスが間
> 違ってるとかっていうオチもないわけでは無かったりします(^^;)
わはは、、、、(最初はそれかと思ったのですが、、、)

> debianというか、apacheな内容ですので、Apacheのml等の方が詳細に教えてく
> れるかもしれません..って、www.apache.or.jp今見れない?(--;;
すみませんです。Debianな方たちのほうが、なにやらベクトルが合うみ
たいでして、、、ついこちらに投稿させていただきました。

> ・Apacheのドキュメントに目を通す
> ・httpd.confを見直す
> で、道は開けるはずです。
> がんばってください〜
本当にありがとうございます。
ここで、身に付けたスキルをいつかだれかの為になれるよう日々精進い
たします。

以上、誠にありがとうございました。

--
□■□■□■□■□■□■□■□■
北信テレネックス 福井支店
早川 厚
Tel  0776-67-3220
Fax 0776-67-3225
HP 090-2126-6040
□■□■□■□■□■□■□■□■

投稿者 xml-rpc : 2004年11月 8日 18:17
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/27650
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。