2004年11月 5日

[debian-users:41878] Re: カーネル再構築でエラーになります

下野です。

 
> >現状は堀内さんに教えて頂いたサイトからstableの最新版の2.4.19とunstableの
>  
>  というのは何のことでしょう?
>  (過去のメールを探して手繰るのも結構手間ですので、なるべく URI
>   を記載する癖をつけてくれるとありがたいです)

すみません、この↓URLです。

http://packages.debian.org/cgi-bin/search_packages.pl?keywords=kernel-source-2.4&searchon=names&subword=1&version=all&release=all

今後は一緒に記載するよう気をつけます。

>
>  
> >こちらはmake menuconfigで必要な物が組み込まれていないと出るということでした
> >ので、make menuconfigの設定を調べてみます。
>
>  oldconfig はされていない、ということでしょうか。

oldconfig も menuconfigもしました。
後から思ったのですがmenuconfig時に何も設定変更しなければむだでしたでしょうか。
現在の私の解釈は、旧バージョンのカーネル用のconfigファイルを使用する際に新
バージョンのカーネルで新たにできた設定項目を設定するのがoldconfig、設定を新規
に、もしくは設定を変更する場合はmenuconfigを使用する、と考えているのですが正し
いでしょうか。


>
>  Linux Kernel のセキュリティホールのことを考えるのであれば
> ----------------------------------------------------------------------
>  ・自分でやるよりは Debian Project 提供のパッケージのほうが楽だし
>   経験豊富な人に任せたほうが安全だ、と考えるならパッケージを利用。
>
>  ・自分での構築が手間(&問題)でなければ、なるべく最新のものを
>    kenrel.org から取得して構築。
> ----------------------------------------------------------------------
>  
>  testing/unstable はセキュリティ対応は基本的に考慮されていません。
>  参考 http://www.debian.org/security/faq#testing
>
>  よって「セキュリティホールのことを考えると unstable または testing
>  の最新版を選ぶ」のは間違いだと判ります。
>
>  #新しいのが入ってくる結果として unstable が安全になることはある
>   でしょう。結果論として、です。個人的には testing の意味合いは
>   中途半端すぎてイマイチだと思っています。だからこそ、backports.org
>   のミラーなどやっているわけですが :-)

詳しい解説ありがとうございます。
Debian Project 提供のパッケージのstableの最新版を使用します。
(機能的に新しいカーネルが必要になった場合はunstableをとりあえず使うか、自分で
つくるか悩ましいです。)


>  よくわからない「どこかのサイト」よりは、まずは公式情報である debian.org
>  の中を探すようにしましょうよ :-) せっかく訳していただいてる方も
>  多数いらっしゃるわけですし。
>
> http://www.debian.org/security/faq#oldversion は答えになりませんか?
>  

はい、十分な答えがありました。
トップページから上記のページに辿りつけました。debian.orgをもっと読まなければ
いけないと反省しました。

投稿者 xml-rpc : 2004年11月 5日 17:33
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/27564
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。