2004年11月 3日

[debian-users:41860] Re: カーネル再構築でエラーになります

From: shimono@xxxxx
Subject: [debian-users:41859] Re: カーネル再構築でエラーになります
Date: Wed, 3 Nov 2004 23:05:51 +0900
> どこかのサイトでDebianから提供されるパッケージはバージョンが最新でなくても
> セキュリティパッチはあたっている、というような記述を見た覚えがあります。

おおざっぱにいえば、そのとおりです。安定版では、セキュリティ問題を
修正する場合、upstream(上流、オリジナル)で修正されたバージョンを
使うのではなく、セキュリティ問題だけを修正するように対処します。

単純にバージョンをあげると、仕様が変更になった場合にほかの
ソフトウェアとの整合性がとれなくなります。また、機能拡張が
あった場合は、バグが入り込む可能性があります。これらの理由のため、
Debian安定版ではできるだけ元のバージョンを変更せずに対処しています。

ですので、みかけのバージョンは古いままでもセキュリティ問題は
解決していたりします。

(ほんとにあらゆる有名な問題が対処されているかは未確認。無保証とは
いっても、僕は大体において信用しています。めんどくさいし(ぉぃ))

> そう
> であれば安定性を優先すればstableの最新版を、新機能を優先するのであればunstable
> かtestingを使用するべきなのかと思いますがいかがでしょうか。

細かいことを言わなければ、そのとおりです。

話は戻りますが、Debianで提供しているLinuxカーネルには、たくさんの
パッチが適用されています。そのため、自分が使いたいカーネルパッチが
あたらない場合があります。こういうときは、オリジナルのカーネルソースを
使うことになります。
--
喜瀬“冬猫”浩


投稿者 xml-rpc : 2004年11月 3日 23:53
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/27509
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。