2004年11月 3日

[debian-users:41859] Re: カーネル再構築でエラーになります

下野です。

やまねさん、喜瀬“冬猫”浩さん、堀内さん、松田陽一@三鷹さん、水野さん、
色々とご指導、ご意見ありがとうございます。

私がカーネルの再構築をしようとしたのは以下の理由によります。

1.インストールするH/WのNICがbcm5700のため、標準のインストーラでは
  認識できないのでドライバを組み込む必要があったからです。
2.カーネルバージョンを2.4.22としたのは、bf24でインストールすると

  カーネルが2.4.18だったので、どうせ再構築するならバージョンをあげ
  ようと思いました。特に2.4.22のバージョンでなければならない理由が
  あったわけではありません。ただ、最新よりも少し時間のたった物の方
  が内容的に落ち着いているかな?という程度の判断でした。

make dep をしたのは、make menuconfigすると最後に次のメッセージが出た
のと、ネット上のインストールの解説でも記述されているところがあったか
らです。

ーーーーーーーーーーーーーーーーーーーーーーーー
*** Next, you must run 'make dep'.
ーーーーーーーーーーーーーーーーーーーーーーーー


/usr/share/doc/kernel-package/README.gz で必要なパッケージとインストール
方法を確認しました。パッケージと方法については問題ないようでした。
(もっとも私の英語力の問題で解釈が間違っているという可能性がありますが・・)

現状は堀内さんに教えて頂いたサイトからstableの最新版の2.4.19とunstableの
最新版の2.4.27をダウンロードして、両方とも無事カーネルの再構築及びbcm5700
の組込ができました。
また、再度kernel.orgから2.4.22をダウンロードし、カーネルの再構築をトライし
てみましたが初めに質問させていただいたのと同じエラーがでてしまいました。
こちらはmake menuconfigで必要な物が組み込まれていないと出るということでした
ので、make menuconfigの設定を調べてみます。

あと、また質問で申し訳ないのですがDebianから提供されているパッケージで、安
定性を考えるのであれば、stableの最新版を選ぶべきなのでしょうか?それとも、
セキュリティホールの事を考えるとunstableまたはtestingの最新版を選ぶべきなので
しょうか?
どこかのサイトでDebianから提供されるパッケージはバージョンが最新でなくても
セキュリティパッチはあたっている、というような記述を見た覚えがあります。そう
であれば安定性を優先すればstableの最新版を、新機能を優先するのであればunstable
かtestingを使用するべきなのかと思いますがいかがでしょうか。

以上よろしくお願いします。


投稿者 xml-rpc : 2004年11月 3日 23:05
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/27508
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。