2010年12月24日

[debian-announce:00070] Exim への攻撃観測とセキュリティ更新についての注意喚起

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- -----------------------------------------------------------------------------
Debian JP Project

    Exim への攻撃観測とセキュリティ更新についての注意喚起

2010年12月24日                      board@xxxxx
- -----------------------------------------------------------------------------

 Debian のデフォルトメールサーバパッケージである Exim に、細工を施した SMTP
通信にてバッファオーバーフローを引き起こし root 権限を外部から取得される脆弱
性が発見されています。外部から侵入を受ける脆弱性は既に Debian では修正済(*1)
ではありますが、既に攻撃プログラムが公開されて容易に入手できる状態であり、
この修正を適用していなかったサイトが被害に遭うケースが現在報告されています。


- -------------------------------------------------------------------------------
■確認■
- -------------------------------------------------------------------------------

 Debian による公開サーバを運用されている方は、以下の点をチェックしてください。

 * メールサーバを Exim4 で運用していないかどうか。Exim4 は Debian において、
  メールサーバが必要になる場合に依存関係上、自動的にインストールされること
  があります。 (この脆弱性は Postfix などの他のメールサーバでは発生しません)。

 * Exim4 をインストールしている場合、外部からのメールを受け取る設定になって
  いるかどうか。ローカル配送専用のメールサーバとして Exim4 が導入されている
  場合は、外部からは攻撃を受けにくくなりますが、依然としてローカルユーザから
  は攻撃が可能な点にご注意ください。

 * セキュリティ更新が配布された2010年12月10日以降に更新を実施しているかどうか。
  以下のようにして、Exim4 パッケージがセキュリティ更新されたものであるかを
  確認してください (現在のところ 4.69-9+lenny1 以上であれば問題ありません)。

  $ dpkg -s exim4 | grep Version
  Version: 4.69-9+lenny1

 * 適切に更新を行っていなかった場合、既に被害にあっていないかどうか。バック
  ドアが仕掛けられていないかどうかを確認ください (*2)


- -------------------------------------------------------------------------------
■対策■
- -------------------------------------------------------------------------------
 * すぐに Exim4 のアップデートを実施してください。
  例: aptitude update; aptitude safe-upgrade

 * 最新のセキュリティ更新情報が送付される debian-security-announce メーリング
  リストの購読(*3) やセキュリティ更新情報の RSS(*4) の取得を検討ください
  (日本語訳は debian-users メーリングリストに投稿されています)。

 * apticron パッケージを使った自動更新の確認などを検討ください。


 今回の問題は、容易に侵入を許し root 権限を奪われる非常に危険なケースです。
十分に注意・確認をお願いします。なお、今回の更新に加えて権限昇格に対する Exim4
の修正アップデートが配布される予定がありますので、そちらも併せて適用ください。


*1) http://www.debian.org/security/2010/dsa-2131
 *2) http://www.debian.or.jp/blog/exim4-security-update.html
 *3) http://lists.debian.org/debian-security-announce/
 *4) http://www.debian.org/security/dsa

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAk0Umq4ACgkQIu0hy8THJktiHgCcDPi6XCTvGpjz5O3HcQgGY/4a
7+kAn2e+wr8ysGG80V8To8fKT2wWqjOp
=/OEz
-----END PGP SIGNATURE-----


投稿者 xml-rpc : 2010年12月24日 22:08
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/100956
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。