2006年3月16日

[cola:10325] strcompat 0.9.2.3 Released - UNIX SVR 4.2 Compatibility Modules for Linux Fast-STREAMS

strcompat-0.9.2.3 was released under GPLv2 on March 15, 2006.

The STREAMS Compatibility Modules package provides the ability for both
Linux Fast-STREAMS and the deprecated Linux STREAMS (LiS) to exhibit
source level compatibility with a wide range of UNIX STREAMS
implementations. Also, it provides source compatibility with Linux
Fast-STREAMS for Lis, and LiS (source and some 2.18.0 binary)
compatibility for Linux Fast-STREAMS. The objective of the package is

to provide source level compatibility with a wide range of UNIX STREAMS
implementations permitting drivers and modules to port easily to Linux
Fast-STREAMS from any other STREAMS implementation, making it possible
to release drivers and modules from a single UNIX code base with minimal
localisms for Linux.

This is the OpenSS7 Project's third separate release of the OpenSS7
STREAMS Compatibility Modules that were formerly present in the Linux
Fast-STREAMS streams-0.7a.2 release package. These compatibility
modules provide source level compatibility with AIX, HPUX, OSF/1, MacOT,
Mentat, SUX, Solaris, SUPER/UX, IRIX, LiS, UnixWare, UXP/V and SVR 4.2
STREAMS. The package contains all the necessary manual pages and other
documentation in an autoconf tarball.

This release is primarily to support additional compilers (gcc 4.0.2),
architectures (x86_64, SMP, 32-bit compatibility), recent Linux
distributions (EL4, SuSE 10, LE2006, OpenSuSE) and kernels (2.6.15). It
includes:

- Corrections for and testing of 64-bit clean compile and test runs on
x86_64 architecture. Some bug corrections resulting from gcc 4.0.2
compiler warnings.

- Changes to satisfy gcc 4.0.2 compiler.

- Corrected build flags for Gentoo and 2.6.15 kernels as reported on
mailing list.

- Initial corrections for and testing of SMP operation on Intel 630
Hyper-Threaded SMP on x86_64. This package should now run well on
N-way Xeons even with Hyper-Threading enabled.

- Corrections and validation of 32-bit compatibility over 64-bit on
x86_64. Should apply well to other 64-bit architectures as well.

This is public beat test release of the package: it deprecates
previous releases. Please upgrade before reporting bugs on previous
releases.

As with other OpenSS7 releases, this release configures, compiles,
installs and builds rpms for a wide range of Linux 2.4 and 2.6 RPM-based
distributions, and can be used on production kernels without patching or
recompiling the kernel.

This package is released under the 'GNU Public License Version 2'. The
release is available as an autoconf/RPM tarball, SRPM and set of binary
RPMs. See the download page < http://www.openss7.org/download.html>; for
the autoconf tarballs and SRPMs. See the strcompat package page at
< http://www.openss7.org/strcompat_pkg.html>; for tarballs, SRPMs and
binary RPMs.

See < http://www.openss7.org/codefiles/strcompat-0.9.2.3/ChangeLog>; and
< http://www.openss7.org/codefiles/strcompat-0.9.2.3/NEWS>; in the release
for more information. Also, see the strcompat.pdf manual in the release
(also in html < http://www.openss7.org/strcompat_manual.html>;).

For the news release, see < http://www.openss7.org/rel20060315_5.html>;

--
Brian F. G. Bidulock
bidulock@xxxxx
http://www.openss7.org/

##########################################################################
# Send submissions for comp.os.linux.announce to: cola@xxxxx #
# PLEASE remember a short description of the software and the LOCATION. #
# This group is archived at http://stump.algebra.com/~cola/ #
##########################################################################


投稿者 xml-rpc : 2006年3月16日 21:20
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/42565
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。