2010年10月20日

[Announce 88] [announce] Apache HTTP Server 2.2.17 and 2.0.64Released


The Apache Software Foundation and the Apache HTTP Server Project are
pleased to announce the release of version 2.2.17 of the Apache HTTP
Server ("Apache"). This version of Apache is principally a bug fix
release, and a security fix release of the APR-util 1.3.10 dependency;

* SECURITY: CVE-2010-1623 (cve.mitre.org)
Fix a denial of service attack against apr_brigade_split_line().


* SECURITY: CVE-2009-3560, CVE-2009-3720 (cve.mitre.org)
Fix two buffer over-read flaws in the bundled copy of expat which
could cause httpd to crash while parsing specially-crafted
XML documents.

We consider this release to be the best version of Apache available, and
encourage users of all prior versions to upgrade.

Apache HTTP Server 2.2.17 is available for download from:

http://httpd.apache.org/download.cgi

Apache HTTP Server 2.0.64 legacy release is also currently available,
with the same vulnerability correction as well as many others fixed in
2.2.16 and earlier releases. See the corresponding CHANGES files linked
from the download page. The Apache HTTP Project developers strongly
encourage all users to migrate to Apache 2.2, as only limited and less
frequent maintenance is provided for legacy versions.

Apache 2.2 offers numerous enhancements, improvements, and performance
boosts over the 2.0 codebase. For an overview of new features
introduced since 2.0 please see:

http://httpd.apache.org/docs/2.2/new_features_2_2.html

Please see the CHANGES_2.2 file, linked from the download page, for a
full list of changes. A condensed list, CHANGES_2.2.17 provides the
complete list of changes since 2.2.16. A summary of all of the security
vulnerabilities addressed in this and earlier releases is available:

http://httpd.apache.org/security/vulnerabilities_22.html

This release includes the Apache Portable Runtime (APR) version 1.4.2
and APR Utility Library (APR-util) version 1.3.10, bundled with the tar
and zip distributions. The APR libraries libapr and libaprutil (and
on Win32, libapriconv version 1.2.1) must all be updated to ensure
binary compatibility and address many known security and platform bugs.

This release builds on and extends the Apache 2.0 API. Modules written
for Apache 2.0 will need to be recompiled in order to run with Apache
2.2, and require minimal or no source code changes.

http://svn.apache.org/repos/asf/httpd/httpd/branches/2.2.x/VERSIONING

When upgrading or installing this version of Apache, please bear in mind
that if you intend to use Apache with one of the threaded MPMs (other
than the Prefork MPM), you must ensure that any modules you will be
using (and the libraries they depend on) are thread-safe.
--
Apache Japan, Announce Mailing List
http://www.apache.jp/mailman/listinfo/announce


投稿者 xml-rpc : 2010年10月20日 01:27
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/99268
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。