2009年10月13日

[Apache-Users 7463] Re:opensslのバージョンアップについて

** Apache ユーザーズメーリングリスト **
** 注意:このメールへの返信は Apache-Users へ行きます **


>> --enable-shared は無くて、--enable-mods-shared=most と
>> したほうがよさそうですが。
> モジュール単位で無効化もできるんで楽っちゃ楽ですけど、お試しのhttpdで無
> いならあまりオススメしませんね。


何がオススメでないのかと(?)だったのですが、most の
ところでしょうか?

元の ando さんの

> apacheのコンパイル方法
> ./configure --enable-so --enable-shared --enable-ssl --with-ssl=/usr/local/ssl --enable-mime-magic

に対して、--enable-shared というオプションは存在しませんよ。
というのが、私のコメントの趣旨です。
そのうえで、--enable-shared と書いたのは、マニュアルで言う、
--enable-mods-shared=most という意味でしょうかね。
と、言いたかったのであって、それがオススメかどうかは別問題。

結局、ando さんがやりたいことが、

1. とりあえず、現在動いている httpd の libssl を最新にしたい。
2. 今後も libssl を更新して httpd を再起動すれば OK にしたい。

のどちらかで、やるべきことが変わってきますよね。

1. は、簡単で、既に libssl.so を最新に更新できたようなので、
apache の build ディレクトリで、 make clean, make, make install
して、apache を再起動すればOK.

2. をやりたいなら、--enable-shared --enable-ssl のところを、
--enable-mods-shared=ssl
にして、make clean, make, make install.
さらに、httpd.conf に
LoadModule ssl_module modules/mod_ssl.so
を追加して再起動といったところでしょう。


--
菊地時夫 tkikuchi@xxxxx
http://weather.is.kochi-u.ac.jp/
〒780-8520 高知大学理学部情報科学教室
--
入退会・変更・配送一時停止は以下へ
http://www.apache.jp/mailman/listinfo/apache-users


投稿者 xml-rpc : 2009年10月13日 21:40
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/89399
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。