2009年10月 9日

[Apache-Users 7456] Re:opensslのバージョンアップについて

** Apache ユーザーズメーリングリスト **
** 注意:このメールへの返信は Apache-Users へ行きます **


andoです

鶴谷さま、回答ありがとうございます

> 静的にリンクされているものは、ライブラリだけを更新しても
> だめです。
> apacheをビルドする際に、httpd本体かモジュールにライブラリ自身が
> 埋め込まれているので、ライブラリだけを更新しても何も変わりません。

# strings /usr/local/apache2/bin/httpd | grep "OpenSSL 0.9.8"
の結果で0.9.8bがありました

# strings /usr/local/ssl/bin/openssl | grep "OpenSSL 0.9.8"
の結果は0.9.8kです

httpd本体に埋め込まれているものを変更するには
apacheの再インストールが必要なのでしょうか
それともsharedでconfigし、apacheを再起動すれば大丈夫ですか?
httpd.confやhttpd-ssl.confなどを変更しているので、なるべく影響がないようにしたいと考えています

apacheのコンパイル方法
./configure --enable-so --enable-shared --enable-ssl --with-ssl=/usr/local/ssl --enable-mime-magic


_________________________________________________________________
メール一括チェック!他の無料メールもプロバイダーメールも。
http://welovewindowslive.spaces.live.com/blog/cns!6029A5A1C44FA6D3!557.entry
--
入退会・変更・配送一時停止は以下へ
http://www.apache.jp/mailman/listinfo/apache-users


投稿者 xml-rpc : 2009年10月 9日 11:14
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/89300
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。