2009年10月 6日

[Apache-Users 7450] Re:opensslのバージョンアップについて

** Apache ユーザーズメーリングリスト **
** 注意:このメールへの返信は Apache-Users へ行きます **

こんにちは、鶴谷です。

安藤 かおり <n_nzzz@xxxxx> さん>

> ** Apache ユーザーズメーリングリスト **

> ** 注意:このメールへの返信は Apache-Users へ行きます **
>
>
> andoです
>
>
>
> おがわさま、回答ありがとうございます
>
>
>
> > Apacheの再起動をしても反映されなかった様子ですので,
> > OpenSSLはApache側に静的リンクされているのでしょう。
> > なので「apacheに何か手を加えることが必要」と思います。
> > httpd -V とか,httpd -l とか叩いてみると良いでしょう。
> >
> > Solaris 9にはOpenSSLがついて来ないはずですので,別途入れた
> > のでしょうが,その時の手順書とか探してみましょう。
>
>
> 0.9.8bの時も今回と同様に、インストールしています
>
> # ./config
> # make
> # make install
>
> どちらもconfigにオプションをつけていないので、静的リンクされていると思います

静的にリンクされているものは、ライブラリだけを更新しても
だめです。
apacheをビルドする際に、httpd本体かモジュールにライブラリ自身が
埋め込まれているので、ライブラリだけを更新しても何も変わりません。


---
鶴谷直樹
turutani@xxxxx
--
入退会・変更・配送一時停止は以下へ
http://www.apache.jp/mailman/listinfo/apache-users


投稿者 xml-rpc : 2009年10月 6日 20:04
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/89230
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。