2008年8月26日

[Apache-Users 7104] Re:Apache2.2の--enable-soがインストールできない

** Apache ユーザーズメーリングリスト **
** 注意:このメールへの返信は Apache-Users へ行きます **

 以下のメール、FreeBSD-Users Mailing Listと勘違いして書いており
ました。

apache-users Mailing Listですので、以下の情報が必要ですね。
以下のmakeした環境は、FreeBSD-6.3-stableです。

Linux系のOSでは、まだapache 2.2はインストールしておりません。

In <20080826.174554.71148553.oniuda@xxxxx>
at Tue, 26 Aug 2008 17:45:54 +0900 (JST)
Re:[ Re: [Apache-Users 7103] Apache2.2の--enable-soがインストールできない ]
Koh-ichi Oniuda (鬼生田浩一) <oniuda@xxxxx> wrotes:
oniuda> 鬼生田です。
oniuda>
oniuda>  ぼくも、apache 2.2などはportsを使わずソースからmakeしています
oniuda> が、portsのpatchは取捨選択してあてています。
oniuda>
oniuda> /usr/ports/www/apache22/files/
oniuda>
oniuda> 2.2.9をmakeした際、あてたパッチ一覧です。
oniuda> patch-mpm-itk-20070425-00
oniuda> patch-srclib-apr-buildconf
oniuda> patch-srclib-apr-utils-buildconf
oniuda> patch-srclib:apr-util:build:dbm.m4
oniuda> patch-srclib:apr-util:config.layout
oniuda> patch-srclib:apr:Makefile.in
oniuda> patch-srclib:apr:build:apr_hints.m4
oniuda> patch-srclib:apr:build:buildcheck.sh
oniuda> patch-srclib:apr:config.layout
oniuda>
oniuda> patchをあてたあと、
oniuda> ./configure --with-z --enable-so  --enable-ssl=shared
oniuda> --enable-suexec=shared --with-suexec-caller=www --enable-rewrite=shared
oniuda> などとして、makeしています。
oniuda>
oniuda> phpも問題なく、soファイル作成されます。
oniuda>
oniuda> ご参考までに。
oniuda>
oniuda> In <619e57540808260134l74d4a5f1o270e7e9784321abb@xxxxx>
oniuda> at Tue, 26 Aug 2008 17:34:12 +0900
oniuda> Re:[ [Apache-Users 7103] Apache2.2の--enable-soがインストールできない ]
oniuda> aug721@xxxxx wrotes:
oniuda> aug721> ** Apache ユーザーズメーリングリスト **
oniuda> aug721> ** 注意:このメールへの返信は Apache-Users へ行きます **
oniuda> aug721>
oniuda> aug721> オカムラと申します。
oniuda> aug721>
oniuda> aug721> Apache2.2のインストールがうまくできずに困っています。
oniuda> aug721>
oniuda> aug721> ./configure --enable-so
oniuda> aug721> とすると、下記のような警告が表示されます。
oniuda> aug721> configure: WARNING: Unrecognized options: --enable-so
oniuda> aug721>
oniuda> aug721> とりあえず無視して、PHPをインストールしてみましたが、
oniuda> aug721> ./configure --enable-mbstring --with-unixODBC
oniuda> aug721> --with-apxs2=/usr/local/apache2/bin/apxs
oniuda> aug721> 警告通り、下記のようなエラーが表示されます。
oniuda> aug721> apxs:Error: Sorry, no shared object support for Apache.
oniuda> aug721>
oniuda> aug721> Apacheのconfigure --helpには、--enable-soは存在していますが、なぜ、認識されないのでしょうか?
oniuda> aug721>
oniuda> aug721> 解決方法、お気づきの点があれば教えて下さい。

---
Oniuda
--
入退会・変更・配送一時停止は以下へ
http://mm.apache.jp/mailman/listinfo/apache-users


投稿者 xml-rpc : 2008年8月26日 17:54
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/76661
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。