2012年6月28日

Re: Problems with draft/sent folders

> > > Now I see that I sometimes have "Fcc:" correctly filled in the header,
> > > (which makes testing much easier). If I start writing a draft from the
> > > Folder-buffer (pressing "w") I have to re-select the template by
> > > cycling through them with C-c C-j for the "Fcc:" to show up. I was
> > > expecting C-c C-e to have the same effect, but no, it doesn't set
> > > "Fcc".
> >
> > Try below code. When writing a draft from Folder buffer by "w",

> > wl-draft-parent-folder is not set.
(snip)
> I tried the code above but everything is as previously described when
> doing "w" (or M-x wl-folder-write) in Folder-buffer, i.e. it starts a
> new draft from my non-gmail account, but "Fcc" isn't in the header and
> sending it won't produce a copy in my "Sent" folder.
>
> When in this "wl-folder-write" started draft I did an Eval:
> wl-draft-parent-folder and it returns:
> #("GMAIL" 0 5 (wl-folder-entity-id 1 wl-folder-is-group is-group))
>
> Which I suspect might not be correct?

I expect you run wl-folder-write from the top position of the folder
group. In that case, wl-draft-parent-folder is set to the name of
the group.

If you want to apply a template in such condition, try adding below
code, or modify your wl-draft-config-alist's value directly.

(add-to-list
'wl-draft-config-alist
'((string= "GMAIL" wl-draft-parent-folder)
(template . "gmail")))

--
Kazuhiro Ito


投稿者 xml-rpc : 2012年6月28日 04:01
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/110390
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。