2012年2月 9日

Re: text coding code in mails


Thanks Dave and Herbert for the help. I got the mime-button thing
under control now, I think, (added it to the FAQ).

>I only have:
>(setq wl-summary-showto-folder-regexp ".*Sent*")

Thanks, this works, if I include another dot, like so:

(setq wl-summary-showto-folder-regexp ".*Sent.*")

Someone on #emacs told me you have to escape the regexp characters
once for the elisp interpreter. I don't have a clue whether this is
true or not, but comparing the above, with M-: eval, this does the same
thing:
(setq wl-summary-showto-folder-regexp "\.\*Sent\.\*")

Also, to complicate things further, I have two different IMAP folders
with sent mails, one of them is called "Sent", the other one is called
"Skickat" so I've tried something like this:

(setq wl-summary-showto-folder-regexp ".*Sent.*|.*Skickat.*")

but this doesn't work.


> Date: Mon, 6 Feb 2012 20:09:24 +0100
> From: hskuhra@xxxxx
> Subject: Re: text coding code in mails
> To: wl-en@xxxxx
>
> On Mon, 6 Feb 2012 18:35:47 +0100
> Karl F <cthulhu_54@xxxxx> wrote:
>
> > Hi!
> > I've been working a while on setting up wanderlust, and I have some questions.
> >
> > Q1.
> > In some messages (all sent from a hotmail address it would seem) I get something looking like:
> > " [1 <text/plain; iso-8859-1 (quoted-printable)>]"
> > starting and ending each message.
> >
> > Is this what is referred to as a "mime-button" on the mailing list? I saw a message talking about "mime buttons" and the fix was apparently to use "Vitaly's patch of 2011-04-06". Is this relevant to me, and if so how do I apply it? I'm using wl installed from el-get (2.15.9). (I see the same behavior in wl-beta.deb on Debian).
>
> If you always want to hide them you can try:
>
> (setq mime-view-buttons-visible nil)
>
> You can toggle them with 'C-c m'.
>
> > Q2.
> > Is it possible to have multiple email addresses in ~/.addresses bound to one alias/nick name? Like a group?
>
> Obviously not. Maybe bbdb?
>
> > Q3
> > In my sent folder, I'd like the summary to show who it was sent
> > _to_, not _from_, since they're all from me. I've tried
> > somethinglike this:
> > (setq
> > ;;show who I sent the mail to in sent-folder.
> > wl-summary-showto-folder-regexp ".*"
> > wl-summary-showto-folder-regexp "%INBOX.Sent.*"
>
> The latter overwrites the first.
>
> > wl-summary-from-function 'wl-summary-default-from)
>
> I only have:
>
> (setq wl-summary-showto-folder-regexp ".*Sent*")
>
> and I have added all my e-mail addresses to:
>
> (setq wl-user-mail-address-list
> '("xxxxx")
> ("yyyyy"))
>
> --
> Herbert
>

投稿者 xml-rpc : 2012年2月 9日 02:14
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/108576
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。