2011年11月 1日

Re: wl and davmail

At Mon, 31 Oct 2011 21:49:41 +0100,
David Maus wrote:
> Okay, this looks like a server problem:
>
> > [07:49:34] <- elmo-imap49 uid fetch 1,25 (body.peek[header.fields (Subject From To Cc Date Message-Id References In-Reply-To Delivered-To)] rfc822.size flags)
> > [07:49:34] -> * 1 FETCH (UID 1)
> > [07:49:34] -> * 10 FETCH (UID 25)
> > [07:49:34] -> elmo-imap49 OK UID FETCH completed

>
> WL requests the email headers for messages with id 1 and 25 but the
> server does not return the requested information. Maybe this is a
> configuration issue with DavMail?

Yeah, I'm considering that but DavMail is very low on settings and it
seems to work properly in thunderbird, for whatever that is worth.

I notice that when I try to get into the mailbox this shows in the
server log

2011-10-31 18:20:08,171 DEBUG [ImapConnection-32856] davmail - Search: SELECT "http://schemas.microsoft.com/exchange/permanenturl","DAV:uid","http://schemas.microsoft.com/mapi/proptag/x0e230003","http://schemas.microsoft.com/exchange/permanenturl","http://schemas.microsoft.com/mapi/proptag/x10f3001f","http://schemas.microsoft.com/mapi/proptag/x10900003","http://schemas.microsoft.com/mapi/proptag/x10810003","DAV:getlastmodified","http://schemas.microsoft.com/mapi/proptag/x0e060040","http://schemas.microsoft.com/mapi/id/{00062008-0000-0000-c000-000000000046}/0x8570" as deleted,"http://schemas.microsoft.com/mapi/proptag/x10830003","http://schemas.microsoft.com/mapi/proptag/x0e070003","urn:schemas:httpmail:read","http://schemas.microsoft.com/mapi/proptag/x0e080003" FROM SCOPE('Shallow TRAVERSAL OF "/exchange/********@*****/Inbox"') WHERE ("DAV:isfolder" = false And "DAV:ishidden" = false And ("urn:schemas:httpmail:read" = false))

shows but when i just run M-x wl and the count on the inbox is correct
it shows...

2011-10-31 18:20:07,641 DEBUG [ImapConnection-32856] davmail - Search: SELECT "http://schemas.microsoft.com/exchange/permanenturl","DAV:uid","http://schemas.microsoft.com/mapi/proptag/x0e230003","http://schemas.microsoft.com/exchange/permanenturl","http://schemas.microsoft.com/mapi/proptag/x10f3001f","http://schemas.microsoft.com/mapi/proptag/x10900003","http://schemas.microsoft.com/mapi/proptag/x10810003","DAV:getlastmodified","http://schemas.microsoft.com/mapi/proptag/x0e060040","http://schemas.microsoft.com/mapi/id/{00062008-0000-0000-c000-000000000046}/0x8570" as deleted,"http://schemas.microsoft.com/mapi/proptag/x10830003","http://schemas.microsoft.com/mapi/proptag/x0e070003","urn:schemas:httpmail:read","http://schemas.microsoft.com/mapi/proptag/x0e080003" FROM SCOPE('Shallow TRAVERSAL OF "/exchange/*******@******/Inbox"') WHERE ("DAV:isfolder" = false And "DAV:ishidden" = false)

Notice the lack of
"And ("urn:schemas:httpmail:read" = false))" in the second line. I'm
assuming this has something to do with it? Other than that as far as i
can tell these lines are the same...

投稿者 xml-rpc : 2011年11月 1日 10:27
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/107281
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。